Cannot add stocks to portfolio


I am unable to add stock to my existing portfolio. Not sure is it because of the drop down of the portfolio, as I tried but could not create new portfolio too.

Hi there,

Can you tell me more? What did you tried to do?
Note that you cannot literally add stock to your portfolio. You need to create BUY transactions instead. e.g. Create a BUY transaction of 100 shares of AAPL to “add” 100 shares of Apple to your portfolio.

Again, can you tell me more? Are you not able to do it here? → Add/Edit Portfolio - StocksCafe (Assuming you are using desktop or laptop)


Hi Evan,

I managed to add in the transaction using the desktop version. For mobile version, I continued to face issue. I think issue is probaby the portfolio cannot drop down for me to choose the transaction to be added.

Hi there,

You mean you cannot select portfolio on this page? → StocksCafe

I checked your account and everything seems in place leh. Hmm…

Evan, not sure why, I can’t even load the link you sent.

Oh… Can you try the following?

  1. Ensure that you first go to to login first then try the link again.

  2. If still cannot, send me the screenshot of what is the issue.

  3. Try another browser and/or device. This might help isolate the issue.

Hi Evan,

It works on the mobile site. I realise it didn’t because I was using the app. Just check the app is not supported anymore?

Yes, App is not supported anymore (at least for now). => Goodbye Mobile App – StocksCafe Blog