Custom Assets - 2 minor issues

I have been experimenting with the new Custom Assets feature, which is very useful. I ran into a few small isues.

  1. When I created a Custom Asset with a number as Symbol, it could not be found back correctly when adding the first transaction. It looks like it is found, but the transaction is not saved correctly. (In case you wonder why I would chose a fully numeric symbol; I was trying to use the ticker of this Korean share as the Symbol).

  2. I tried to add a Dividend to my Custom Asset through this route: Custom Asset β†’ Click on Symbol β†’ Dividend β†’ Details β†’ Add New System-wide Dividend (There is no other option). You are then asked to proof the Source of the Dividend etcetera, while it is a Custom Asset.
    I later learned from your YouTube video that I should use Dividends β†’ Override β†’ Add Collected Dividend
    It might be useful to also redirect the route I described above to the Add Collected Dividend, because it is also a common sense route to add dividends to your Custom Assets.

  3. When you add an initial transaction of a Custom Asset, save it, and later change your mind and switch to another new Custom Asset Symbol by editing that initial transaction, all kinds of things start to go wrong. It looks like the newly inserted Custom Asset does not have a price (although the system could get it from the initial transaction data). It is not possible to manually add a new price to this new Custom Asset, because an error message that the former EOD price is missing, will appear.
    It can now only be solved by making a whole new intial transaction with that new Custom Asset.

Other than these minor issues, things seem to go well !

Hi there,

Thank you for the suggestions.

I just tested it (using 123) and it seems fine. I think it cannot be easily found because too many symbols out there are mostly numeric. I suggest to prefix with CA (e.g. CA:123) should be fine then.

Actually, for CA, it is okay to use the add system-wide dividend when it is a Custom Assets.
I do agree that I should remove the requirement for proof though. β†’ Done.
Also, I agree that adding the link directly for personalized override would be helpful β†’ Done.

Sorry, I do not fully understand this.
Did you mean that you changed the symbol of the Custom Asset? Or did you change the symbol of the transaction?


I changed the StockCode of the transaction. So to recap the whole process:

  1. Create new Custom Asset, eg symbol NWECORP
  2. Add the first transaction with this new Custom Asset and save it with Add
  3. I change my mind about the new Custom Asset, for example the Symbol I chose has a misspelling, so I make a new Custom Asset: NEWCORP
  4. I find back the transaction mentioned under 2. back and edit it. I change the StockCode to CA:NEWCORP. I leave the transaction unchanged otherwise and press Update.
  5. The new Custom Asset NEWCORP now has no Prices !
  6. If we attempt to add a price, an error message appears: Cannot find previous EOD

This situation can only be solved by deleting the transaction and make a brand new first transaction with NEWCORP, but not every user may get that idea.

Thanks for the detailed steps. I will investigate further.

Hi there,

I have made some changes to handle the above.

  1. When you change the symbol, the new Custom Assets will also β€œreceive” the price
  2. Even when there is not previous EOD, you can add the first EOD without issue.


1 Like