Dividend Override for Keppel DIS Not Showing Up


I tried adding a dividend override for Keppel per the instructions here: Keppel O&M merge with SCM - #20 by evankoh but although I receive the message “Dividend Override Successfully Added” it doesn’t show up in the Overrides tab.

I’ve tried entering it twice - once as a Cash transaction and once without ticking the “Cash” option.

Am I looking in the right place for the override? I’ve checked the other dividend tabs and also selected the right portfolio. I do see an older override for Sembcorp in the list (not in screenshot for privacy reasons).

Hi there,

  1. I just tried and I was able to enter the Dividend Override without issue.

  2. In this article, I actually suggested two ways to handle it (treat as StockSplit or scrip dividend), you prefer to handle it as Scrip Dividend?

  3. If you prefer to handle it as StockSplit, there is actually an event already created for you to easily accept it → StocksCafe

  4. If you prefer to handle it as Scrip Dividend, can you try again and let me know what you entered for each field for me to try to replicate the issue.


Hi @evankoh thanks for checking this out on a Sunday!

I tried adding it again and it worked. I tracked the issue to the content of the “Type” field. It looks like only alphanumeric chars are accepted, but periods, colons, etc. are not. I was trying to use Type as a description to indicate this is tied to the 19:1 distribution.

If I try to update the override and enter a Type string that contains one of these special characters, the system correctly displays a failure message.

However, if I add a new Override where Type contains one of the restricted characters, it says it was added successfully but it never actually shows up.

Perhaps you can have the instructions indicate that only alphanumeric chars are allowed in the Type field and return an error if the creation failed .

One other thing I noticed - if I try to edit an existing override, the default portfolio selected in editing differs from the portfolio the override is assigned to (I have ~6 portfolios).

Hope this helps.

Thanks again!

Ok please ignore the above update - even Types with special characters are added successfully.

However for your reference I can reproduce the failure with this Type content:
“19.085 SembMarine (S51) for 1 (Valued@$0.127/S51 share on First Possible Sale Date on 28 Feb 2023)”

Not sure what the issue is - length? Other magic chars? Anyway it’s probably an abuse of the Type field so probably exceeds some limit / validation. I’ve worked around it, so i’m good, just FYI in case it’s useful.

Thanks for the detailed bug report. I will look into it!

Done. Found the reason. There is length limit of 45 characters on Type. Anyway, I have removed that limit. You can put in what you like now :slight_smile:

1 Like