Invalid Date Error

I’m trying to put all my past transaction into my portfolio but when I put a historical date, I get an invalid date error


Hmm… I cannot replicate it on my android phone nor the iphone simulator.

Can you give me more details? Feels like somehow the time is also included which is why it was not successful.

Btw, can you try a workaround as well? 1) Create transaction with today’s date since your post seems to suggest that you only have issue with past dates. 2) Then edit that transaction to that 11 May 2020.

Meanwhile, I will think about how to replicate this issue.


Tried your workaround same results, I’m using Huawei Mate 20 Pro if that helps.


Thank you for trying it out. Okay. I made some code changes based on the error message. However, you would have to verify it for me since I was not able to replicate the error on my side.

Can you check and let me know if that helps?



Worked all good now! But it doesn’t seem to appear on my overview even after I refresh it, it’s coming on the other tabs “Transaction, dividend etc”

Thank you so much! Looking forward to using your platform

I see. I believe I know and have fixed the issue.

I updated the mobile app. Please close the app and open it again. (You might have to repeat it up to 2 times. Ensure that you are on v0.7.58)

Thank you for reporting!

Have the same issue on web version - I believe it is still there.

Tried including a past transaction, eg. 06 March 2020.

If I follow the format prompt of dd/mm/yyy -> My input of 06/03/2020, will reflect 3 Jun 2020.
-> My workaround was to input as 03/06/2020 for it to reflect 6 March 2020

No solution for December dated transactions
-> Can’t reflect a 16 December 2020 transaction with the workaround
-> Input of 16/12/2020 (format prompt dd/mm/yy) will return me 12 December 2020

Appreciate if it can be fixed, thanks.

Tried to input the correct date on the mobile app and hoping it will be streamed correctly into the web version - it doesn’t.

The correct date can be included in the mobile app, but when opening the web version the date jumps again. This causes the data to be picked up incorrectly and calculate values, such as average price, incorrectly.

For the web, I think it depends on the browser. My browser format is actually MM/DD/YYYY.

Can you try this format instead then?

Yeah I did too. It throws an error if the day value is more than 12 for MMDDYYYY.

Interesting. Can you tell me your setup?

  1. What browser are you using?

  2. It is for desktop web right?

I tried repopulating everything again. Works now. Thanks for looking at this!

1 Like