Unable to Delete Manually Added Dividend

After the cromwell stock split, the previous dividend from previous ticker was not added into the new ticker. I tried adding the dividends manually. However, after manually trying to add the dividend for cromwell, i made some mistakes & was unable to delete it no matter how many times i tried clicking the delete symbol / logo

Hi there,

Usually, for stocksplit, we “considered” the old ticker transactions to be closed. Hence the dividends would be tagged to the closed positions and can be found here → https://stocks.cafe/portfoliov2/closedpositions?label_ids=0

It looks like you can already delete it now? Let me know if you are still facing issues.

Cheers,
Evan

I’m still having issues deleting it. After clicking the delete button, it brings me to the page as shown in the picture attached.


No matter where i click afterwards, the thing won’t be deleted. Perhaps i might be missing something.

You can simply ignore that page. That page is shown simply because usually when people delete dividends, it is because they have chosen stocks/shares instead of cash (i.e. scrip dividend).

Would you like to tell me which dividend you are trying to delete? (What is the ExDate, Shares and Amount?) I can try to delete for you.

Btw, I am seeing something weird at the override page → https://stocks.cafe/portfoliov2/override

Maybe you want to remove everything there and start again.

1 Like

Yeap. That worked. Thank you very much :slight_smile:

1 Like

Great! Enjoy your weekend~